Jump to content
Klions

Meu servidor não funciona

Recommended Posts

Olá a todos, bom, estou tendo problema com meu servidor local.

 

Segui este tutorial para montar o servidor:

 

E este tutorial para o Steam Token:

 

Aparece isso no link

Please login or register to see this link.

Please login or register to see this code.

Mas não acho nada na lista de servidores no jogo, mesmo tentando adicionar como favorito. Aparece um texto de falha ao tentar conectar usando o "connect 138.204.139.41:27015" no console do jogo. (Oq eu fiz com a minha vida jesus)

Obs: Já adicionei os códigos "sv_lan 0" e "sv_pure 0".

Obs²: Já possuo porta aberta 27015 no modem.

Obs³: Não aparece nenhum log de erro em lugar algum.

 

Alguém pode me ajudar? Desde já, grato a todas as respostas.

Share this post


Link to post
Share on other sites

Pelo que vi está tudo certo.

Quando você tenta se conectar só aparece este erro mesmo?

47 minutos atrás, Klions disse:

Aparece um texto de falha ao tentar conectar usando o "connect 138.204.139.41:27015" no console do jogo. (Oq eu fiz com a minha vida jesus)

 

Verifique o LOG de erros do servidor e veja se não tem nenhum log de erros lá, se tiver copie o que estiver nele e cole aqui.

 

Verifique novamente se abriu as porta corretamente no roteador.

 

Em relação aos tokens, comandos lan, pure, você colocou aonde, no server.cfg?

Share this post


Link to post
Share on other sites
Citar

Quando você tenta se conectar só aparece este erro mesmo?

Aparece isso no console do jogo:

Please login or register to see this code.

 

Citar

Verifique o LOG de erros do servidor e veja se não tem nenhum log de erros lá, se tiver copie o que estiver nele e cole aqui.

Nenhum erro

 

Citar

Verifique novamente se abriu as porta corretamente no roteador.

Meu modem não possui nenhuma porta bloqueada, a internet que possuo oferece todas as portas desbloqueadas

 

Citar

Em relação aos tokens, comandos lan, pure, você colocou aonde, no server.cfg?

Coloquei no server.cfg, no autoexec.cfg e logo após que abre o servidor eu digito no prompt

 

Pelo visto não vai ter solução :/

Share this post


Link to post
Share on other sites

Aproveitando o tópico, criei um servidor dedicado de CS:GO, consegui entrar e jogar nele, coloquei até pluguins. Só que nenhum amigo meu consegue entrar nele, acredito que seja devido às portas do roteador. Apesar delas apareceram como abertas, quando eu fui testar em sites elas estavam closed, acredito que seja esse o problema, fora isso, como eu poderia tornar o server público para aparecer nos servidores da comunidade? Se conseguirem resolver esses 2 problemas ajudaria muito.

Share this post


Link to post
Share on other sites
1 hora atrás, Klions disse:

Meu modem não possui nenhuma porta bloqueada, a internet que possuo oferece todas as portas desbloqueadas

Sim, a internet sua está liberada todas as portas, mas roteadores se não estou enganado bloqueia certas portas mesmo assim, por isso é sempre bom abrir mesmo assim.

 

Para abrir basta procurar o modele do seu roteador na internet e ver como abrir portas nele.

 

56 minutos atrás, Lpalermo disse:

Aproveitando o tópico, criei um servidor dedicado de CS:GO, consegui entrar e jogar nele, coloquei até pluguins. Só que nenhum amigo meu consegue entrar nele, acredito que seja devido às portas do roteador. Apesar delas apareceram como abertas, quando eu fui testar em sites elas estavam closed, acredito que seja esse o problema, fora isso, como eu poderia tornar o server público para aparecer nos servidores da comunidade? Se conseguirem resolver esses 2 problemas ajudaria muito.

Sobre sua dúvida quando for assim crie um tópico seu assim não polui o de outro usuário.

 

Mas enfim, seu caso é porta bloqueada também, faça mesma coisa que falei para o @Klions, abra a porta em seu roteador também.

 

Sobre o segundo problema, acredito que liberando as portas ele mostra automaticamente na lista da comunidade.

Share this post


Link to post
Share on other sites

Esse é um problema tipico de servidores caseiros: Portas bloqueadas no modem e Firewall.

 

infelizmente não tem o que fazer, a única maneira do servidor funcionar é você conseguindo liberar as portas no modem e também no firewall do windows.

Para isso, existem vários tutoriais na internet ensinando, basta buscar pelo modelo do modem.

Share this post


Link to post
Share on other sites

Estou exatamente com o mesmo problema...

 

Servidor criado, token OK, mas só aparece LAN...

 

Já liberei as portas no modem e no firewall do windows, e nada.

Share this post


Link to post
Share on other sites

Ah, liberei as portas no firewall do windows e funcionou!

  • Like 1

Share this post


Link to post
Share on other sites

Acho que da primeira vez que liberei no firewall não tinha dado

Share this post


Link to post
Share on other sites

×